php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74254 Data judgment problem
Submitted: 2017-03-16 03:40 UTC Modified: 2017-03-16 03:46 UTC
From: 290605830 at qq dot com Assigned:
Status: Not a bug Package: Output Control
PHP Version: 7.0.16 OS: windows 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: 290605830 at qq dot com
New email:
PHP Version: OS:

 

 [2017-03-16 03:40 UTC] 290605830 at qq dot com
Description:
------------
162.95 multiplied by 100 and not equal to 16295, the other digits tested were normal

Test script:
---------------
$a = 162.95;
$b = 16295;


$c = (double)($a*100);
$b = (double)$b;


if($c!=$b)
{
	
	echo "<br/>not eq ,c=".$c.",b=".$b;
	
}else{
	
	echo "eq";
	
}

Expected result:
----------------
The result of running this script should be equal

Actual result:
--------------
Actual results are not equal

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-03-16 03:46 UTC] jhdxr@php.net
-Status: Open +Status: Not a bug
 [2017-03-16 03:46 UTC] jhdxr@php.net
Floating point values have a limited precision. Hence a value might 
not have the same string representation after any processing. That also
includes writing a floating point value in your script and directly 
printing it without any mathematical operations.

If you would like to know more about "floats" and what IEEE
754 is, read this:
http://www.floating-point-gui.de/

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Aug 13 09:05:44 2022 UTC