php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7415 possible bug in crypt function
Submitted: 2000-10-23 15:49 UTC Modified: 2000-11-03 12:22 UTC
From: design at worldsoft-unlimited dot nl Assigned:
Status: Closed Package: *Function Specific
PHP Version: 4.0.3pl1 OS: linux 2.2.16
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: design at worldsoft-unlimited dot nl
New email:
PHP Version: OS:

 

 [2000-10-23 15:49 UTC] design at worldsoft-unlimited dot nl
i use the script below to generate a user reference code
and worked well for a couple of years.

a few days ago my hostprovider upgraded to PHP-4.0.3pl1
and my script stopt working as it supposed to.

<?php
....
$today = date("Y-m-d",time());
$dateemail = $today ."-".$emailaddress;
$code= crypt($dateemail);
...
?>

when entering different value's for $emailaddress en using
different dates the script generates the same code.

can you tell what the problem is.




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-03 12:22 UTC] sniper@php.net
This should be fixed in CVS now.

--Jani
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Mar 19 19:01:28 2019 UTC