php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74062 Apache2.4.25(Win64) and rrd_tool provided for PHP 7.1 is don't present
Submitted: 2017-02-08 16:07 UTC Modified: 2017-02-12 20:44 UTC
From: evgeny_4 at mail dot ru Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 7.1.1 OS: Windows Server 2012 r2
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: evgeny_4 at mail dot ru
New email:
PHP Version: OS:

 

 [2017-02-08 16:07 UTC] evgeny_4 at mail dot ru
Description:
------------
Apache server provided for PHP 7.1 and rrd_tool is missing.


Test script:
---------------
My steps for were setup:

1) was Installed - successfully
2) was Installed PHP - successfully
3) Iwas Installed rrd_too - successfully

4) Test rrd with PHP 
   c:\php-7.1.1-Win32-VC14-x64>php --ri rrd

   rrd

   rrd tool module => enabled
   rrd tool module version => 2.0.1
   rrdtool library version => 1.6.0


5) After start of Apache server - successfully, but in log file of php appear Warning 
->  PHP Warning:  PHP Startup: Unable to load dynamic library 'c:/php-7.1.1-Win32-VC14-x64/ext/php_rrd.dll'  

And in listing of phpinfo()   I could not find information about rrd tool.






I use the packages:

c:\php-7.1.1-Win32-VC14-x64>php --ri rrd

rrd

rrd tool module => enabled
rrd tool module version => 2.0.1
rrdtool library version => 1.6.0

c:\Apache24\bin>httpd -v
Server version: Apache/2.4.25 (Win64)
Server built:   Dec 17 2016 11:15:57

c:\php-7.1.1-Win32-VC14-x64>php -v
PHP 7.1.1 (cli) (built: Jan 18 2017 18:38:49) ( ZTS MSVC14 (Visual C++ 2015) x64 )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2017 Zend Technologies











Expected result:
----------------
Information about rrd tool.

Actual result:
--------------
phpinfo() doesn't have information about rrd tool

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-02-12 19:24 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2017-02-12 19:24 UTC] ab@php.net
Hints about Apache was already given in bug #74043.

Thanks.
 [2017-02-12 20:44 UTC] evgeny_4 at mail dot ru
Unfortunately, I could not find package php7 with existing  mod_rrd.so.
Can you sent to my this one ? 

P.S.
I use OS - WIndows Server 2012 r2

Thanks.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 02 17:03:35 2021 UTC