php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74047 No way to compare multibyte UTF-8 strings??
Submitted: 2017-02-05 17:50 UTC Modified: 2017-02-05 20:08 UTC
From: teo8976 at gmail dot com Assigned:
Status: Not a bug Package: *Unicode Issues
PHP Version: 5.6.30 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: teo8976 at gmail dot com
New email:
PHP Version: OS:

 

 [2017-02-05 17:50 UTC] teo8976 at gmail dot com
Description:
------------
Just like there is a strcmp() function for comparing strings byte-by-byte, there should exist a mb_strcmp() function to compare multibyte strings according to a given encoding, e.g. 'UTF-8'. Actually, it should be according to an encoding and collation.

And please don't call it a feature request. It's simply RIDICULOUS that, at the very least, UTF-8 string comparison is not available in 20fucking17.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-02-05 17:52 UTC] teo8976 at gmail dot com
-Summary: No way to compare multibyte UTF-8 strings?? +Summary: ___ -Status: Open +Status: Closed
 [2017-02-05 17:52 UTC] teo8976 at gmail dot com
seems intl does it.
 [2017-02-05 20:08 UTC] requinix@php.net
-Summary: ___ +Summary: No way to compare multibyte UTF-8 strings?? -Status: Closed +Status: Not a bug
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Sep 24 13:01:24 2020 UTC