php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #73969 segfault on debug_print_backtrace
Submitted: 2017-01-21 19:30 UTC Modified: 2017-01-22 13:49 UTC
From: ryan dot brothers at gmail dot com Assigned: tpunt
Status: Closed Package: Reproducible crash
PHP Version: 7.1.1 OS: Linux
Private report: No CVE-ID:
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ryan dot brothers at gmail dot com
New email:
PHP Version: OS:

 

 [2017-01-21 19:30 UTC] ryan dot brothers at gmail dot com
Description:
------------
When running the below script on PHP 7.1.1, a segmentation fault occurs when calling debug_print_backtrace().

There are 2 files below: 1.php and 2.php

To run it, run:

php 1.php

It seems to be related to the method aliasing for the trait for c2::f1 as f2.  If that line is removed, the script runs cleanly.


Test script:
---------------
1.php:

<?php
trait c2
{
	public static function f1()
	{

	}
}

class c1
{
	use c2
	{
		c2::f1 as f2;
	}

	public static function go()
	{
		return require('2.php');
	}
}

c1::go();

=======

2.php:

<?php
debug_print_backtrace();


Expected result:
----------------
#0  require() called at [/tmp/1.php:19]
#1  c1::go() called at [/tmp/1.php:23]


Actual result:
--------------
#0  c1::Segmentation fault

Patches

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-01-22 13:49 UTC] tpunt@php.net
-Assigned To: +Assigned To: tpunt
 [2017-01-22 14:44 UTC] andrew dot nester dot dev at gmail dot com
Hi! I've just added pull request on GitHub which fixes this problem.
 [2017-01-22 16:12 UTC] krakjoe@php.net
Automatic comment on behalf of andrew.nester.dev@gmail.com
Revision: http://git.php.net/?p=php-src.git;a=commit;h=6f912f7c045ae723d01a24504bf0ae0711fd8a4f
Log: Fixed #73969 - Fixed segmentation fault when debug_print_backtrace called
 [2017-01-22 16:12 UTC] krakjoe@php.net
-Status: Assigned +Status: Closed
 [2017-02-16 21:50 UTC] homepage186 at gmail dot com
XPLRAY
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Tue Aug 29 15:01:52 2017 UTC