php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #73945 php myadmin and prestashop not working
Submitted: 2017-01-16 10:21 UTC Modified: 2017-01-16 10:25 UTC
From: sarathb764 at gmail dot com Assigned:
Status: Not a bug Package: MySQLi related
PHP Version: 7.0.14 OS: ubuntu
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: sarathb764 at gmail dot com
New email:
PHP Version: OS:

 

 [2017-01-16 10:21 UTC] sarathb764 at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/book.mysqli
---
phpMyAdmin - Error

The mysqli extension is missing. Please check your PHP configuration. See our documentation for more information.
2)Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /var/www/html/prestashop6/prestashop/classes/db/MySQL.php:51 Stack trace: #0 /var/www/html/prestashop6/prestashop/classes/db/Db.php(319): MySQLCore->connect() #1 /var/www/html/prestashop6/prestashop/classes/db/Db.php(239): DbCore->__construct('localhost', 'root', 'sbt', 'pres') #2 /var/www/html/prestashop6/prestashop/config/alias.php(66): DbCore::getInstance() #3 /var/www/html/prestashop6/prestashop/classes/shop/Shop.php(329): pSQL('10.254.101.52') #4 /var/www/html/prestashop6/prestashop/config/config.inc.php(114): ShopCore::initialize() #5 /var/www/html/prestashop6/prestashop/index.php(27): require('/var/www/html/p...') #6 {main} thrown in /var/www/html/prestashop6/prestashop/classes/db/MySQL.php on line 51


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-01-16 10:25 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2017-01-16 10:25 UTC] requinix@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Dec 05 12:03:38 2021 UTC