php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #73918 selected language ignored
Submitted: 2017-01-12 11:18 UTC Modified: 2017-01-30 12:13 UTC
Votes:6
Avg. Score:4.7 ± 0.7
Reproduced:6 of 6 (100.0%)
Same Version:2 (33.3%)
Same OS:2 (33.3%)
From: meghesanovidiu at yahoo dot com Assigned:
Status: Re-Opened Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: meghesanovidiu at yahoo dot com
New email:
PHP Version: OS:

 

 [2017-01-12 11:18 UTC] meghesanovidiu at yahoo dot com
Description:
------------
i search for a php function on google, which lands me on the function page in the php doc. it automatically selects the language (romanian for me). i choose english.
the next time i repeat the procedure (from the search), i land again on the php site on the romanian version so i have to change the language again. the site should keep my language option in a cookie and respect it. it's annoying to change it every time i come to the site...



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-01-12 13:06 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2017-01-12 13:06 UTC] cmb@php.net
If the language is explicitly specified in the URL, it overrides
the selected language. Compare the behavior of the following URLs
with regard to the selected language:

  <http://php.net/manual/function.strpos.php>
  <http://php.net/manual/en/function.strpos.php>
  <http://php.net/manual/ro/function.strpos.php>

Only the first URL will respect the selected language; the others
will choose the language given in the URL.
 [2017-01-18 08:26 UTC] meghesanovidiu at yahoo dot com
yeah, but since i can't control what urls google returns to my search (i already tried setting the language of the results, with no visible effects), i expect the php site to respect my choice.
 [2017-01-30 12:13 UTC] cmb@php.net
-Status: Not a bug +Status: Re-Opened -Assigned To: cmb +Assigned To:
 [2017-01-30 12:13 UTC] cmb@php.net
The PHP manual has hreflang links, so search engines should cater
to that. It may be, however, that there's something wrong with
the hreflang links. I don't have time to investigate on this,
though.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Aug 04 18:01:24 2020 UTC