php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #73861 SNMP works only for port 161
Submitted: 2017-01-04 16:20 UTC Modified: 2017-01-04 18:26 UTC
From: layer1 dot 0 at gmx dot de Assigned:
Status: Closed Package: SNMP related
PHP Version: 7.1.0 OS: Ubuntu 16.04
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
47 + 23 = ?
Subscribe to this entry?

 
 [2017-01-04 16:20 UTC] layer1 dot 0 at gmx dot de
Description:
------------
Hi, i try to fetch SNMP Data from JVM running SNMP Adaptor on Port 1161. 
It's not working via php cause the SNMP Class and SNMP functions always seem to use port 161.

snmpwalk on OS level with port 1161 (same data) is working fine! 


i tried: 
$syscontact = snmpget($host, "127.0.0.1:1161", ".1");
var_dump($syscontact);
It retruns false 

$session = new SNMP( SNMP::VERSION_2C, "127.0.0.1:1161" , "public" );
var_dump($session); 

object(SNMP)#1 (8) { ["info"]=> array(4) { ["hostname"]=> string(14) "127.0.0.1:1161" ["port"]=> int(1161) ["timeout"]=> int(-1) ["retries"]=> int(-1) } ["max_oids"]=> NULL ["valueretrieval"]=> int(0) ["quick_print"]=> bool(false) ["enum_print"]=> bool(false) ["oid_output_format"]=> int(0) ["oid_increasing_check"]=> bool(true) ["exceptions_enabled"]=> int(0) } 

Here i would expect hostname = 127.0.0.1 but it is hostname + port. Maybe this is not working correctly.







Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-01-04 16:23 UTC] layer1 dot 0 at gmx dot de
sorry for c&p error 

i tried: 
$syscontact = snmpget("127.0.0.1:1161", "public", ".1");
var_dump($syscontact);
Returns false
 [2017-01-04 18:26 UTC] layer1 dot 0 at gmx dot de
-Status: Open +Status: Closed
 [2017-01-04 18:26 UTC] layer1 dot 0 at gmx dot de
Works now, but the display is missleading
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Sep 27 23:03:36 2021 UTC