php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #73851 Extend PDO::PARAM_* types with fload/double data type
Submitted: 2017-01-02 13:39 UTC Modified: 2017-01-02 17:44 UTC
From: dorin dot marcoci at gmail dot com Assigned: cmb (profile)
Status: Duplicate Package: PDO Core
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dorin dot marcoci at gmail dot com
New email:
PHP Version: OS:

 

 [2017-01-02 13:39 UTC] dorin dot marcoci at gmail dot com
Description:
------------
To define PDO::PARAM_FLOAT (DOUBLE)

It prevents to return float native types in PDO driver implementations.
Here https://github.com/php/php-src/blob/master/ext/pdo/pdo_stmt.c#L554 floats are not considered and can't be passed in "value" buffer, except using ZVALs.

PDO::PARAM_* types should match ZVAL types where it make sense.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-01-02 17:44 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2017-01-02 17:44 UTC] cmb@php.net
Duplicate of request #43203.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Dec 05 06:01:23 2020 UTC