php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #73732 Sprintf bug for 1.15*100*2^n values
Submitted: 2016-12-13 10:25 UTC Modified: 2016-12-13 10:35 UTC
From: teodor dot danciu at gmail dot com Assigned:
Status: Not a bug Package: Strings related
PHP Version: Irrelevant OS: Irrelevant
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: teodor dot danciu at gmail dot com
New email:
PHP Version: OS:

 

 [2016-12-13 10:25 UTC] teodor dot danciu at gmail dot com
Description:
------------
sprintf("%03d ",(1.15*100)); and values multiplied by 2 return wrong values
ex 114 instead of 115

Test script:
---------------
$price=1.15*100;
echo sprintf("%03d ",$price); // prints 114 instead of 115

$price=1.15*100*2;
echo sprintf("%03d ",$price); // prints 229 instead of 230

$price=1.15*100*4;
echo sprintf("%03d ",$price); // prints 459 instead of 460

$price=1.15*100*8;
echo sprintf("%03d ",$price); // prints 919 instead of 920

$price=1.15*100*10;
echo sprintf("%03d ",$price); // prints 1149 instead of 1150


Patches

Sprintf-bug-for-some-values (last revision 2016-12-13 10:30 UTC by teodor dot danciu at gmail dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-12-13 10:35 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2016-12-13 10:35 UTC] requinix@php.net
Floating point values have a limited precision. Hence a value might 
not have the same string representation after any processing. That also
includes writing a floating point value in your script and directly 
printing it without any mathematical operations.

If you would like to know more about "floats" and what IEEE
754 is, read this:
http://www.floating-point-gui.de/

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Dec 08 10:01:24 2019 UTC