php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #73658 Transliterator::create broken since icu-58 upstream changes
Submitted: 2016-12-05 18:26 UTC Modified: 2018-05-12 19:20 UTC
From: sjon at hortensius dot net Assigned:
Status: Not a bug Package: intl (PECL)
PHP Version: 7.1.0 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sjon at hortensius dot net
New email:
PHP Version: OS:

 

 [2016-12-05 18:26 UTC] sjon at hortensius dot net
Description:
------------
Like #73655; this is caused by icu-58. This works fine with icu-57,

Test script:
---------------
print Transliterator::create('de_DE')->transliterate("Donnerl├╝ttchen");


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-05-12 19:20 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2018-05-12 19:20 UTC] ab@php.net
Thanks for the report. The changes in the transliteration ID handling, same as any other ICU data, are not a PHP responsibility. Use Transliterator::listIds() to find out the suitable values. For a simple variant, I guess what you wanted is 

$t = Transliterator::create("latin-ascii"); var_dump($t->transliterate("Donnerl├╝ttchen"));

Thanks.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Feb 27 17:01:29 2020 UTC