php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #73567 wiki.php.net uses unsupported PHP version
Submitted: 2016-11-20 16:35 UTC Modified: 2018-02-24 15:48 UTC
Votes:2
Avg. Score:3.0 ± 2.0
Reproduced:1 of 2 (50.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: me at kelunik dot com Assigned: cmb (profile)
Status: Closed Package: Systems problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: me at kelunik dot com
New email:
PHP Version: OS:

 

 [2016-11-20 16:35 UTC] me at kelunik dot com
Description:
------------
https://wiki.php.net/ is currently running PHP 5.5.9 according to the X-Powered-By header: "PHP/5.5.9-1ubuntu4.20". PHP 5.5 is EOL. If we can't even keep PHP's own infrastructure up-to-date, how can we reasonably expect users of PHP to do so?

Test script:
---------------
curl -s --head https://wiki.php.net/ | grep PHP

Expected result:
----------------
Runs a supported version of PHP, currently at least 5.6. At best, it should run the most recent version, so 7.0.x.

Actual result:
--------------
Runs unsupported version 5.5.x. Canonical will fix only very critical vulnerabilities.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-11-25 21:21 UTC] stas@php.net
-Type: Security +Type: Bug
 [2018-02-24 15:48 UTC] cmb@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: cmb
 [2018-02-24 15:48 UTC] cmb@php.net
That should have been resolved in the meantime.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Mar 01 10:01:28 2024 UTC