php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #73565 --with-config-file- can`not effect
Submitted: 2016-11-19 02:35 UTC Modified: 2016-11-22 06:31 UTC
From: 961365124 at qq dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 7.1Git-2016-11-19 (Git) OS: ubuntu 16.04
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: 961365124 at qq dot com
New email:
PHP Version: OS:

 

 [2016-11-19 02:35 UTC] 961365124 at qq dot com
Description:
------------
I clone php-src from github.version is 7.2.0-dev.I use `./configure --prefix=/usr/local/php7 --with-config-file-path=/usr/local/php7/etc`

`./php-fpm -i | grep ini` found Loaded Configuration File => (none).

and `strace  /usr/local/php7/sbin/php-fpm -i 2>1.log`found

open("/usr/local/lib/php.ini", O_RDONLY) = -1 ENOENT (No such file or directory)

I don`t know why --with-config-file-  can`not effect


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-11-19 11:42 UTC] kalle@php.net
-Status: Open +Status: Feedback
 [2016-11-19 11:42 UTC] kalle@php.net
Hi, is this issue also affected on lower versions than 7.2 (master)? E.g. PHP 7.1.0RC6?
 [2016-11-21 04:13 UTC] 961365124 at qq dot com
-Status: Feedback +Status: Open
 [2016-11-21 04:13 UTC] 961365124 at qq dot com
I know how to show you this case.

command script
----------------
$ ./configure --disable-all
$ make
$ ./configure --prefix=/usr/local/php7 --with-config-file-path=/usr/local/php7/etc
$ make
$ ./sapi/fpm/php-fpm -i | grep Configuration

output 
----------------
Configuration File (php.ini) Path => /usr/local/php7/etc
Loaded Configuration File => (none)

The second `./configure --with-config-file-path=` seems not effect.
 [2016-11-21 04:56 UTC] 961365124 at qq dot com
and the file `/usr/local/php7/etc/php.ini` exist
 [2016-11-22 06:31 UTC] krakjoe@php.net
-Status: Open +Status: Not a bug
 [2016-11-22 06:31 UTC] krakjoe@php.net
You are using a dirty build on the second make.

You must make clean, distclean or ./vcsclean between builds.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu May 19 11:05:44 2022 UTC