php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #73557 Typo error
Submitted: 2016-11-17 20:12 UTC Modified: 2016-11-17 20:17 UTC
From: krishna dot mondeddu at gmail dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: 7.0.13 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: krishna dot mondeddu at gmail dot com
New email:
PHP Version: OS:

 

 [2016-11-17 20:12 UTC] krishna dot mondeddu at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/function.password-hash
---
password_hash document syntax has typo error.


string password_hash ( string $password , integer $algo [, array $options ] )

should be like 

string password_hash ( string $password , integer $algo , [ array $options ] )


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-11-17 20:17 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2016-11-17 20:17 UTC] requinix@php.net
That would mean
  password_hash($password, $algo,)
is valid syntax. It is not.

Putting the comma inside the brackets is common practice in all programming documentation - not just PHP's.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Oct 30 17:01:24 2020 UTC