|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7352 Apache crashes hard when loading Oracle-enabled
Submitted: 2000-10-19 18:10 UTC Modified: 2000-10-20 19:59 UTC
From: jl at carnegietech dot org Assigned:
Status: Closed Package: Apache related
PHP Version: 4.0.3pl1 OS: Linux (RH 6.X)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: jl at carnegietech dot org
New email:
PHP Version: OS:


 [2000-10-19 18:10 UTC] jl at carnegietech dot org
Loading --with-oracle into Apache, httpd -X dumps core without message.  httpd is silent but
httpd never starts.  Same setup --wthout-oracle works fine.
Same occurs if specifying --with-oci8 instead of --with-oracle.

Confirmed this in RH 6.1, 6.2, both with RH Apache RPM
(1.3.9 and 1.3.12).  Tried on kernel 2.2.12, 2.2.14 and
2.2.16.  Tried with and without LDAP (having seen the open
bugs at  Tried with a minimal configuration as well as with several different feature sets. Under not one of these configurations did the problem disappear.  Apache dies summarily, without leaving a core file behind,
printing a message or logging it to its log files.

My current config line is:
./configure --with-apxs --enable-force-cgi-direct --enable-discard-path --enable-calendar --with-gdbm --enable-dbase --without-mysql --with-readline --enable-trans-sid --with-openssl --enable-sockets --enable-memory-limit --with-gnu-ld --enable-sigchild --with-oracle --without-ldap

but I have tried many different configurations and, every
time, apache crashes if --with-oracle and works without it.

Thank you


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2000-10-19 20:22 UTC]
Have you set the environment variables mentioned here:

before starting apache?

 [2000-10-20 19:59 UTC]
User feedback:
 Yes, I had done this.  Thanks.  The problem appears to have been the glibc2.1 bug triggered
(in a way unknown to me) by not compiling Apache with libpthread.  Thanks everyone.



PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed May 18 04:03:41 2022 UTC