php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #73509 static extension compilation problem
Submitted: 2016-11-13 01:37 UTC Modified: 2016-12-14 17:45 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: johnyduck at clovermail dot net Assigned: bukka (profile)
Status: Assigned Package: gnupg (PECL)
PHP Version: 7.0.13 OS: centos 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: johnyduck at clovermail dot net
New email:
PHP Version: OS:

 

 [2016-11-13 01:37 UTC] johnyduck at clovermail dot net
Description:
------------
Make gnupg-1.4.0.tgz extract into /php_sources/ext/gnupg
and then try to 
./configure --prefix=/usr/local/php7013 --enable-fpm --with-fpm-user=lighttpd2 --with-fpm-group=lighttpd2  --enable-bcmath --with-gnupg

Actual result:
--------------
/usr/bin/ld: ext/gnupg/gnupg_keylistiterator.o: undefined reference to symbol 'gpg_strerror'
/usr/bin/ld: note: 'gpg_strerror' is defined in DSO /lib64/libgpg-error.so.0 so try adding it to the linker command line
/lib64/libgpg-error.so.0: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status
make: *** [sapi/cli/php] Error 1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-12-14 17:45 UTC] bukka@php.net
-Status: Open +Status: Assigned -Type: Bug +Type: Feature/Change Request -Assigned To: +Assigned To: bukka
 [2016-12-14 17:45 UTC] bukka@php.net
This is not supported so it's more a feature request...

Anyway why can't you use a shared extension?
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC