php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7349 ldap_add will not work under OpenLDAP 2.x
Submitted: 2000-10-19 15:42 UTC Modified: 2000-11-14 14:02 UTC
From: malmond at vt dot edu Assigned: venaas (profile)
Status: Closed Package: LDAP related
PHP Version: 4.0.2 OS: Linux PPC
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: malmond at vt dot edu
New email:
PHP Version: OS:

 

 [2000-10-19 15:42 UTC] malmond at vt dot edu
I am having problems with PHP 4.0.2 and OpenLDAP 
2.0.4.  When trying to add entries to the LDAP it always 
kicks out an error; ldap_error() reports "Invalid syntax".  I 
know that this is not the case.  I write the entries to a file 
and manually add them no problem.  Nothing in the 
code has changed; the code works fine when talking to 
OpenLDAP 1.2.x  but not for 2.0.x.  (I recompiled, etc. to 
point to the new libraries).  This seems to be a problem 
with the Linux PPC platform only;  on x86 it seems to 
work okay (never have tested in full production).

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-10-19 16:07 UTC] venaas@php.net
Have you tried adding the entries with 2.0.4's ldapadd? If it works
the bug is likely to be in PHP, if it doesn't work you should report
it to the OpenLDAP people. There are some syntaxes that are
valid in OpenLDAP 1 but not implemented in OpenLDAP 2 yet.
Could you try to use PHP with OpenLDAP 2 to add entries into an
OpenLDAP 1 server? If the syntax isn't implemented, it shouldn't
work on x86 either though.

 [2000-11-12 00:13 UTC] sniper@php.net
Please try updating to PHP4.0.3pl1 and OpenLDAP to 2.0.7.
I don't have any troubles with those versions with ldap_add().

--Jani
 [2000-11-14 14:02 UTC] venaas@php.net
Have tested ldap_add() with PHP 4.0.3pl1 and OpenLDAP 2.0.6 on
Linux PPC, unable to reproduce the problem. Don't think can do
much more. Please report if still problems.

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 01 03:05:53 2022 UTC