php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #73482 [PL] array_search: failure return values for PHP <4.2 backwards
Submitted: 2016-11-08 21:20 UTC Modified: 2019-06-01 06:49 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: php dot net at wojtus dot net Assigned: sobak (profile)
Status: Closed Package: Translation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: php dot net at wojtus dot net
New email:
PHP Version: OS:

 

 [2016-11-08 21:20 UTC] php dot net at wojtus dot net
Description:
------------
---
From manual page: http://php.net/manual/pl/function.array-search.php
---

Hi, there's an error in Polish (pl) translation:

There is:
Począwszy od PHP 4.2.0, zamiast FALSE, array_search() zwraca NULL w przypadku niepowodzenia.

Should be:
Począwszy od PHP 4.2.0, zamiast NULL, array_search() zwraca FALSE w przypadku niepowodzenia.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-11-08 22:48 UTC] requinix@php.net
-Summary: wrong translation +Summary: [PL] array_search: failure return values for PHP <4.2 backwards -Status: Open +Status: Verified
 [2016-11-24 05:35 UTC] sobak@php.net
-Assigned To: +Assigned To: sobak
 [2017-10-24 05:13 UTC] kalle@php.net
-Status: Verified +Status: Assigned
 [2019-06-01 06:49 UTC] sobak@php.net
-Status: Assigned +Status: Closed
 [2019-06-01 06:49 UTC] sobak@php.net
Since we have removed the outdated Polish manual I consider this closed. Please refer to the original manual - I honestly think it's very unlikely for the Polish translation to come back to live considering how much it's been lagging behind (this is just one of the examples).

Thank you for the report.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Oct 24 04:01:29 2019 UTC