php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7345 segmentation fault with named virtual hosts en php_value flags
Submitted: 2000-10-19 11:36 UTC Modified: 2000-11-20 10:04 UTC
From: franky dot van dot liedekerke at telenet dot be Assigned:
Status: Closed Package: Apache related
PHP Version: 4.0.3pl1 OS: Solaris 2.6
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: franky dot van dot liedekerke at telenet dot be
New email:
PHP Version: OS:

 

 [2000-10-19 11:36 UTC] franky dot van dot liedekerke at telenet dot be
I'm trying to get apache 1.3.14 to run with php 4.0.3pl1 on Solaris 2.6.
Now I compiled php to use apxs:

"./configure" \
"--with-apxs=/opt/apache-1.3.14/bin/apxs" \
"--prefix=/opt/apache-1.3.14/php" \
"--with-config-file-path=/opt/apache-1.3.14/php/conf" \
"--enable-safe-mode" \
"--enable-trans-sid" \
"--with-exec-dir=/opt/apache-1.3.14/php/bin" \
"--enable-magic-quotes" \
"--with-mysql=/opt/mysql-3.22.32" \
"--with-ldap=/opt/openldap" \
"--with-sybase=/opt/sybase" \
"$@"

And everything seems to start up nicely. Even php works great...partially.
From the moment I try to use a php script from a named virtualhost that is
not the first one defined, the apache child process dies with a segmentation
fault.
Now I discovered that, when I remove the php_admin_value and php_value
entries from my apache config and activate php from the php.ini file,
everything works fine for all named virtual hosts.


Franky

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-19 22:48 UTC] sniper@php.net
Please try a snapshot from http://snaps.php.net/ 
This should be fixed already.

--Jani
 [2000-11-20 10:04 UTC] sniper@php.net
User reported fixed in snapshot.

--Jani
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Jan 21 22:01:23 2021 UTC