php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #73415 Bad copy/pasted test name
Submitted: 2016-10-29 23:42 UTC Modified: 2021-04-07 00:25 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: michael at orlitzky dot com Assigned: ohill (profile)
Status: Closed Package: geoip (PECL)
PHP Version: 7.0.12 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
48 - 35 = ?
Subscribe to this entry?

 
 [2016-10-29 23:42 UTC] michael at orlitzky dot com
Description:
------------
The last test in v1.1.1 has a copy/pasted name:

  PASS Checking geoip_setup_custom_directory() (with trailing slash) 
  [tests/018.phpt] 
  PASS Checking geoip_setup_custom_directory() (with trailing slash) 
  [tests/019.phpt]

It looks like that test checks the IPv6 database, though, so the name is probably a mistake.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-11-03 17:53 UTC] cmb@php.net
-Assigned To: +Assigned To: ohill
 [2021-04-06 23:50 UTC] ohill@php.net
-Status: Assigned +Status: Closed
 [2021-04-06 23:50 UTC] ohill@php.net
Code is correct on GitHub.
 [2021-04-06 23:52 UTC] ohill@php.net
-Status: Closed +Status: Re-Opened
 [2021-04-06 23:52 UTC] ohill@php.net
Actually a file is missing in the package.. reopening to keep track.
 [2021-04-07 00:25 UTC] ohill@php.net
-Status: Re-Opened +Status: Closed
 [2021-04-07 00:25 UTC] ohill@php.net
Test was indeed a bad cut/paste that went into the package archive without a commit. Test was not correct, updated and put in source control. Sorry about that.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Jun 13 13:01:24 2021 UTC