php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #73199 NumberFormatter::formatCurrency for BYN currency
Submitted: 2016-09-28 19:22 UTC Modified: 2018-05-04 12:19 UTC
From: roocster at gmail dot com Assigned:
Status: Not a bug Package: intl (PECL)
PHP Version: 7.0.11 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: roocster at gmail dot com
New email:
PHP Version: OS:

 

 [2016-09-28 19:22 UTC] roocster at gmail dot com
Description:
------------
It would be nice to have the support of the Belarusian ruble currency format (ISO — BYN 933). Currency format is the same as that of the Russian ruble (RUR).

Test script:
---------------
$fmt = new NumberFormatter('ru-RU', NumberFormatter::CURRENCY);

echo $fmt->formatCurrency(123.45, 'BYN');
echo PHP_EOL;
echo $fmt->formatCurrency(123.45, 'RUR');

Expected result:
----------------
123,45 р.
123,45 р.

Actual result:
--------------
123,45 BYN
123,45 р.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-05-04 12:19 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2018-05-04 12:19 UTC] ab@php.net
Thanks for the report. Certain mappings are done in ICU, PHP doesn't implement it directly. Best way it should be reported to the ICU project, where the Unicode data is maintained.

Thanks.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Feb 28 16:01:29 2020 UTC