php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #73176 Sanitize/Validate Filters on URL don't work for international domains
Submitted: 2016-09-26 10:46 UTC Modified: 2016-09-26 11:49 UTC
From: we at mokraemer dot de Assigned: cmb (profile)
Status: Duplicate Package: Filter related
PHP Version: 5.6.26 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: we at mokraemer dot de
New email:
PHP Version: OS:

 

 [2016-09-26 10:46 UTC] we at mokraemer dot de
Description:
------------
1. international domainnames should be recognized
2. international (utf-8) pathnames should be recognized

Test script:
---------------
1. echo filter_var('http://münchen.de/',FILTER_SANITIZE_URL)
2. echo filter_var('https://de.wikipedia.org/wiki/Übertragungsverlust',FILTER_SANITIZE_URL);

Expected result:
----------------
1. http://münchen.de/
2. https://de.wikipedia.org/wiki/Übertragungsverlust

Actual result:
--------------
1. http://mnchen.de/
2. https://de.wikipedia.org/wiki/bertragungsverlust

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-09-26 11:49 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2016-09-26 11:49 UTC] cmb@php.net
Duplicate of bug #53474.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Aug 18 23:01:26 2019 UTC