php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #73030 segfault in zval_delref_p while running symfony integration tests
Submitted: 2016-09-06 10:16 UTC Modified: 2016-09-22 12:25 UTC
Votes:2
Avg. Score:3.5 ± 0.5
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:1 (50.0%)
From: jean-tiare dot le-bigot at corp dot ovh dot com Assigned:
Status: Duplicate Package: Reproducible crash
PHP Version: 7.1.0RC1 OS: Debian Wheezy
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jean-tiare dot le-bigot at corp dot ovh dot com
New email:
PHP Version: OS:

 

 [2016-09-06 10:16 UTC] jean-tiare dot le-bigot at corp dot ovh dot com
Description:
------------
## Configure line

./buildconf --force
./configure \
 --with-openssl \
 --with-mysqli=mysqlnd \
 --with-pdo-mysql=mysqlnd \
 --prefix=$HOME/usr \
 --enable-fpm \
 --enable-opcache \
 --enable-debug \
 --with-gd \
 --enable-intl \
 --with-jpeg-dir=/usr \
 --with-png-dir=/usr \
 --enable-gd-native-ttf=/usr \
 --with-png-dir=/usr \
 --enable-wddx \
 --with-config-file-path=$HOME/usr/etc \
 --enable-sigchild \
 --enable-short-tags  \
 --disable-rpath \
 --enable-libgcc \
 --with-zlib=/usr \
 --enable-bcmath \
 --enable-calendar \
 --with-curl=/usr \
 --with-gdbm=/usr \
 --enable-ftp \
 --with-gettext=/usr \
 --with-imap \
 --with-kerberos \
 --with-imap-ssl \
 --with-mcrypt=/usr \
 --with-mhash=/usr \
 --with-jpeg-dir=/usr \
 --enable-exif \
 --enable-sysvsem \
 --enable-sysvshm \
 --enable-sysvmsg \
 --enable-zip \
 --enable-inline-optimization \
 --enable-soap \
 --enable-mbstring \
 --enable-mbregex \
 --with-gnu-ld \
 --with-libxml-dir \
 --enable-shared=yes \
 --enable-static=yes \
 --with-xsl=/usr \
 --enable-sockets \
 --with-xmlrpc \
 --with-iconv \
 --with-imagick \
 --enable-pdo \
 --with-pdo-pgsql=/usr \
 --with-xpm-dir=/usr \
 --with-pcre-regex \
 --with-freetype-dir=/usr \
 --with-pspell \
 --with-pgsql=/usr \
 --with-bz2 \
 --with-gmp \
 EXTENSION_DIR=$HOME/usr/lib/php-extensions

## GDB backtrace:

Program received signal SIGSEGV, Segmentation fault.
0x0000000000b41631 in zval_delref_p (pz=0x7faeeb81a050) at /home/jlebigot/dev/php-7.1.0RC1/Zend/zend_types.h:834
834		return --GC_REFCOUNT(Z_COUNTED_P(pz));

(gdb) bt
#0  0x0000000000b41631 in zval_delref_p (pz=0x7faeeb81a050) at /home/jlebigot/dev/php-7.1.0RC1/Zend/zend_types.h:834
#1  0x0000000000b41cae in i_zval_ptr_dtor (zval_ptr=0x7faeeb81a050, __zend_filename=0x11b0bf0 "/home/jlebigot/dev/php-7.1.0RC1/Zend/zend_vm_execute.h", __zend_lineno=899) at /home/jlebigot/dev/php-7.1.0RC1/Zend/zend_variables.h:47
#2  0x0000000000b4bb34 in ZEND_DO_FCALL_BY_NAME_SPEC_RETVAL_USED_HANDLER (execute_data=0x7faeeb819f90) at /home/jlebigot/dev/php-7.1.0RC1/Zend/zend_vm_execute.h:899
#3  0x0000000000b4a832 in execute_ex (ex=0x7faeeb819d30) at /home/jlebigot/dev/php-7.1.0RC1/Zend/zend_vm_execute.h:432
#4  0x0000000000ad4c46 in zend_call_function (fci=0x7ffdb8b38b50, fci_cache=0x7ffdb8b38b20) at /home/jlebigot/dev/php-7.1.0RC1/Zend/zend_execute_API.c:825
#5  0x0000000000867fb3 in reflection_method_invoke (execute_data=0x7faeeb819cc0, return_value=0x7faeeb819990, variadic=0) at /home/jlebigot/dev/php-7.1.0RC1/ext/reflection/php_reflection.c:3326
#6  0x0000000000868119 in zim_reflection_method_invokeArgs (execute_data=0x7faeeb819cc0, return_value=0x7faeeb819990) at /home/jlebigot/dev/php-7.1.0RC1/ext/reflection/php_reflection.c:3359
#7  0x0000000000b4c387 in ZEND_DO_FCALL_SPEC_RETVAL_USED_HANDLER (execute_data=0x7faeeb819790) at /home/jlebigot/dev/php-7.1.0RC1/Zend/zend_vm_execute.h:1097
#8  0x0000000000b4a832 in execute_ex (ex=0x7faeeb815030) at /home/jlebigot/dev/php-7.1.0RC1/Zend/zend_vm_execute.h:432
#9  0x0000000000b4a983 in zend_execute (op_array=0x7faeeb882000, return_value=0x0) at /home/jlebigot/dev/php-7.1.0RC1/Zend/zend_vm_execute.h:474
#10 0x0000000000aec47b in zend_execute_scripts (type=8, retval=0x0, file_count=3) at /home/jlebigot/dev/php-7.1.0RC1/Zend/zend.c:1464
#11 0x0000000000a5b470 in php_execute_script (primary_file=0x7ffdb8b3c200) at /home/jlebigot/dev/php-7.1.0RC1/main/main.c:2533
#12 0x0000000000bd5258 in do_cli (argc=7, argv=0x1a97780) at /home/jlebigot/dev/php-7.1.0RC1/sapi/cli/php_cli.c:990
#13 0x0000000000bd6236 in main (argc=7, argv=0x1a97780) at /home/jlebigot/dev/php-7.1.0RC1/sapi/cli/php_cli.c:1378

(gdb) print pz->value.counted
$3 = (zend_refcounted *) 0x0

## Step to reproduce:

git clone https://github.com/symfony/symfony.git
cd symfony
./phpunit -v --debug --filter testSetContentJsonSerializeError


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-09-22 11:57 UTC] sjon at hortensius dot net
I have reduced this segfault to the following testcase:

https://3v4l.org/nAFVh
 [2016-09-22 12:03 UTC] Sjon at hortensius dot net
This is a duplicate of #73113 which has already been fixed
 [2016-09-22 12:25 UTC] nikic@php.net
-Status: Open +Status: Duplicate
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Dec 07 06:03:35 2021 UTC