php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7303 <Directory> "overflow"
Submitted: 2000-10-18 04:51 UTC Modified: 2000-10-19 03:40 UTC
From: staun at sunsite dot auc dot dk Assigned:
Status: Closed Package: Apache related
PHP Version: 4.0.3pl1 OS: Solaris8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
42 - 25 = ?
Subscribe to this entry?

 
 [2000-10-18 04:51 UTC] staun at sunsite dot auc dot dk
At SunSITE.dk we host many different projects which some of use PHP. These seperate projects each want to use their own prepend directives, and some we want to be more strict on than other. etc. This results in <Directory> directives like this:

<Directory /mnt/www-docs/www-docs/php-share/phorum>
php_admin_flag safe_mode on
php_admin_value open_basedir .:/pack/apache/local/php-safe/phorum/conf
php_admin_flag sql_safe_mode off
</Directory>
etc.

The problem is that we had periodic faults where directives for f.eks.
/lgdc/ would apply themselves to our document root and other sub projects. Like the configuration "overflowed" from subdirectory. As it is a periodic problem it is hard to reproduce, but we stopped this behaviour by adding a <Directory> directive for /mnt/www-docs/.

It seems like the configuration which are applied to the php engine in one apache process are not reset if there is no other directive for the new dir.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-10-18 05:56 UTC] staun at sunsite dot auc dot dk
Warning: open_basedir restriction in effect. File is in wrong directory. in Unknown on line 0

Warning: open_basedir restriction in effect. File is in wrong directory. in Unknown on line 0

Warning: Failed opening 'prepend.php3' for inclusion (include_path='.:/mnt/www-docs/www-docs/SunSITE') in Unknown on line 0

Take a look at http://sunsite.dk/ Reload up to 20 times and it will pop up.

 [2000-10-19 03:40 UTC] staun at sunsite dot auc dot dk
Fixed by 4.0.3pl1.

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Mar 08 07:01:23 2021 UTC