php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #72722 php_ibm_db2.dll fails to load
Submitted: 2016-07-31 15:08 UTC Modified: 2016-08-01 17:30 UTC
From: varreysr at gmail dot com Assigned: cmb (profile)
Status: Duplicate Package: ibm_db2 (PECL)
PHP Version: 7.0.9 OS: Windows 10 64 Bit
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: varreysr at gmail dot com
New email:
PHP Version: OS:

 

 [2016-07-31 15:08 UTC] varreysr at gmail dot com
Description:
------------
Complied using PHP 7.09, Visual Studio 2015 community edition from 64 bit Native tools command prompt. Able to create a dll file but fails while loading from Apache. When I start Apache from command prompt, I am getting the following errors thru VC 2015 debugger :

Unhandled exception at 0x00007FFB15E2E6FC (ntdll.dll) in httpd.exe: 0xC0000374: A heap has been corrupted (parameters: 0x00007FFB15E822B0).


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-07-31 15:16 UTC] varreysr at gmail dot com
Apache server starts without any issues if I comment IBM_DB2 extension file in PHP
 [2016-08-01 17:30 UTC] cmb@php.net
-Summary: With CGi , CLI +Summary: php_ibm_db2.dll fails to load -Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2016-08-01 17:30 UTC] cmb@php.net
That appears to be a duplicate of bug #69852. TL;DR: PECL/ibm_db2 is not yet fit for PHP 7.
 [2016-08-01 17:57 UTC] varreysr at gmail dot com
Here is the call stack before it fails:

 	ntdll.dll!RtlReportCriticalFailure()	Unknown
 	ntdll.dll!RtlpHeapHandleError()	Unknown
 	ntdll.dll!RtlpLogHeapFailure()	Unknown
 	ntdll.dll!RtlpAnalyzeHeapFailure()	Unknown
 	ntdll.dll!RtlpFreeHeap()	Unknown
 	ntdll.dll!RtlFreeHeap()	Unknown
 	ucrtbase.dll!free()	Unknown
 	php7ts.dll!00007ffad6112329()	Unknown
 	php7ts.dll!00007ffad6113eaf()	Unknown
 	php7ts.dll!00007ffad61292fd()	Unknown
 	php7ts.dll!00007ffad6128d4e()	Unknown
 	php7ts.dll!00007ffad6127b42()	Unknown
 	php7apache2_4.dll!00007ffb101630b7()	Unknown
>	php7apache2_4.dll!00007ffb10163243()	Unknown
 	libhttpd.dll!00000000762ce75e()	Unknown
 	httpd.exe!00007ff6ed161eb9()	Unknown
 	httpd.exe!00007ff6ed162ff9()	Unknown
 	[External Code]
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jan 19 05:01:23 2020 UTC