php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7251 Linkage problem when GD is compiled as shared object
Submitted: 2000-10-16 12:28 UTC Modified: 2000-12-07 19:48 UTC
From: timecop at japan dot co dot jp Assigned:
Status: Closed Package: GD related
PHP Version: 4.0.3pl1 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: timecop at japan dot co dot jp
New email:
PHP Version: OS:

 

 [2000-10-16 12:28 UTC] timecop at japan dot co dot jp
when php is compiled with --with-gd=shared,/dir/to/gd, the final link fails because there is a function inside gd.c which is used by the PDF module. (really short one, called php_isize or something like that).
Also, if a shared version of GD is used (some people like me actualy compile a shared version), then when -with-gd is used, it does not properly link with apache because -lgd is not added to the apache module link list because it's assumed that gd is already statically linked to libphp.a

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-27 09:55 UTC] sniper@php.net
Duplicate of #7487
 [2000-12-07 19:48 UTC] sniper@php.net
This should be fixed in CVS.
Please try latest snapshot from http://snaps.php.net/ 

--Jani
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Nov 14 04:01:33 2019 UTC