php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #72485 Test reports not available on qa.php.net
Submitted: 2016-06-24 10:24 UTC Modified: 2018-07-23 21:17 UTC
From: cmb@php.net Assigned: danbrown (profile)
Status: Closed Package: Systems problem
PHP Version: Irrelevant OS: n/a
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: cmb@php.net
New email:
PHP Version: OS:

 

 [2016-06-24 10:24 UTC] cmb@php.net
Description:
------------
A while ago I've noticed that the run_tests.php reports are not
available on <http://qa.php.net/reports/run_tests.php>. The
following error is reported:

| An error occured when reading summary data from 7.0.9-dev DB
| file.

This is still the case.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-07-16 02:21 UTC] cmb@php.net
Any news here?
 [2016-07-28 18:19 UTC] cmb@php.net
-Package: Website problem +Package: Testing related
 [2016-07-28 18:19 UTC] cmb@php.net
Ping
 [2016-07-28 19:54 UTC] webmaster at ajeux dot com
The sqlite database for this version seems corrupted. This needs someone with access to the QA server to fix this.
 [2016-12-10 18:17 UTC] cmb@php.net
Could somebody with access to the QA machine please have a look at this issue?
 [2018-06-07 22:09 UTC] cmb@php.net
-Package: Testing related +Package: Systems problem
 [2018-06-07 22:09 UTC] cmb@php.net
Hopefully addressing the relevant people, now. :)
 [2018-07-22 16:46 UTC] cmb@php.net
-Assigned To: +Assigned To: danbrown
 [2018-07-22 16:46 UTC] cmb@php.net
Daniel, since you have access to sph1.php.net, could you please
take a look at this issue?
 [2018-07-23 00:09 UTC] rasmus@php.net
I had a look. This is the error:

[Sun Jul 22 23:54:13.145334 2018] [:error] [pid 613] [client 50.100.82.232:49156] PHP Warning:  SQLite3::query(): Unable to prepare statement: 1, no such table: reports in /var/www/qa.php.net/reports/reportsfunctions.php on line 165

It turned out there were a bunch of 0-length .sqlite file in the db directory.
I deleted them. They were:
7.1.0alpha1.sqlite 5.6.22RC1.sqlite 5.6.23-dev.sqlite 7.0.7RC1.sqlite 5.5.37-dev.sqlite 7.0.8RC1.sqlite 7.0.8-dev.sqlite 5.5.36.sqlite 5.6.22.sqlite  7.0.9-dev.sqlite 
After deleting them, the page (while slow) seems to work now.

Anyone want to take a look at the qa web code to see why it might occasionally generate 0-length sqlite files?
 [2018-07-23 21:17 UTC] cmb@php.net
> After deleting them, the page (while slow) seems to work now.

Thanks!  It seems it is slow when the .cache files have to be
built[1].

> Anyone want to take a look at the qa web code to see why it
> might occasionally generate 0-length sqlite files?

I don't think it's related to the qa web code.  There are several
documented possibilities why an SQLite database file might be
corrupted[1]; could have been caused by one of these.  I guess
it's not worth the effort to investigate further, unless that
happens again.

[1] <https://github.com/php/web-qa/blob/ccb839f/reports/reportsfunctions.php#L159-L186>
[2] <https://www.sqlite.org/howtocorrupt.html>
 [2018-07-23 21:17 UTC] cmb@php.net
-Status: Assigned +Status: Closed
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Apr 14 17:01:28 2024 UTC