php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #72480 /var/log/php_errors.log filling up with same error
Submitted: 2016-06-23 18:00 UTC Modified: 2016-06-25 13:39 UTC
From: floriparob at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.6.23RC1 OS: Debian
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: floriparob at gmail dot com
New email:
PHP Version: OS:

 

 [2016-06-23 18:00 UTC] floriparob at gmail dot com
Description:
------------
This message is repeated every 30 minutes in /var/log/php_errors.log

[24-Jun-2016 03:09:01 Australia/Melbourne] PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20131226/libsodium.so' - /usr/lib/php5/20131226/libsodium.so: undefined symbol: crypto_box_seal_open in Unknown on line 0

These are the contents of /usr/lib/php5/20131226

root@roblaptop:/usr/lib/php5/20131226# ls -l
total 1412
-rw-r--r-- 1 root root 114168 Jun 16 17:30 gd.so
-rw-r--r-- 1 root root 410912 Jun 16 17:30 intl.so
-rw-r--r-- 1 root root  76032 May 11 17:58 json.so
-rw-r--r-- 1 root root 144040 Nov 24  2015 libsodium.so
-rw-r--r-- 1 root root  48072 Jun 16 17:30 mcrypt.so
-rw-r--r-- 1 root root 156152 Jun 16 17:30 opcache.so
-rw-r--r-- 1 root root  44616 Jun 16 17:30 pdo_pgsql.so
-rw-r--r-- 1 root root 118344 Jun 16 17:30 pdo.so
-rw-r--r-- 1 root root 143224 Jun 16 17:30 pgsql.so
-rw-r--r-- 1 root root 142760 Dec  4  2014 scrypt.so
root@roblaptop:/usr/lib/php5/20131226# 

PHP5 installed from Debian packages. Version is 
5.6.22+dfsg-2

Debian version is
Linux roblaptop 4.6.0-1-amd64 #1 SMP Debian 4.6.1-1 (2016-06-06) x86_64 GNU/Linux


How do I stop this message being written to php_errors.log every 30 minutes?

Thanks,



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-06-23 18:24 UTC] inefedor at gmail dot com
You're getting it every 30 minutes because you've set up your FPM workers to restart every 30 minutes. When they start they encounter this linking warning which is probably caused by the old version of libsodium installed in your system. Refer to this guide to get the compatible versions https://paragonie.com/book/pecl-libsodium/read/00-intro.md#installing-libsodium
 [2016-06-25 13:39 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Package: Session related +Package: *Configuration Issues -Assigned To: +Assigned To: cmb
 [2016-06-25 13:39 UTC] cmb@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu May 19 11:05:44 2022 UTC