php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #72475 enhanced chm uses up huge disk space
Submitted: 2016-06-23 04:59 UTC Modified: 2016-07-03 11:11 UTC
From: jim dot michaels at Jesusnjim dot com Assigned: cmb (profile)
Status: Not a bug Package: Doc Build problem
PHP Version: 7.1.0alpha1 OS: vista32,pae amd
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
41 - 28 = ?
Subscribe to this entry?

 
 [2016-06-23 04:59 UTC] jim dot michaels at Jesusnjim dot com
Description:
------------
the thousands of zip files that are in the chm get extracted into %temp% (you can put that into the breadcrumb menu/address bar of windows explorer) and chew up huge amounts of space and get left there. the sheer amount of dirs make a simple directory listing about 15sec to do that. just look at the range of folder's properties to get disk space used. 37GB.

1 zip file with lots of stuff in the archive (can take trees) takes up less disk space than a whole bunch of little ones, which consume a partial sector and then the rest of the space is wasted*nFiles...

zip and lzma compression do high compression on html or text.

also, php is not working correctly, scripts don't run right in 71a1 or earlier. is there a %2 bug in the c++ compiler's source tree?



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-06-23 15:27 UTC] cmb@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2016-06-23 15:27 UTC] cmb@php.net
> the thousands of zip files that are in the chm get extracted
> into %temp%

I don't understand why you extract the CHM file. That is not
necessary for viewing its contents.

> also, php is not working correctly, scripts don't run right in
> 71a1 or earlier.

Please open a separate ticket for this issue, and supply a
minimal self-contained test script.
 [2016-07-02 10:04 UTC] jim dot michaels at Jesusnjim dot com
-Status: Feedback +Status: Assigned
 [2016-07-02 10:04 UTC] jim dot michaels at Jesusnjim dot com
there's nothing short about this "script" (HTML).
windows seems to be scanning for and extracting every zip file on the hard drive and putting it into %temp%, especially when I run this extended chm.

eliminate the .zip files in the project and see if it works with just running HTML Help 5.0 on it. bug in their docs?

please uncopyright the docs and php, and the web site. send copyright.gov the cancellation. thank you.
 [2016-07-02 10:51 UTC] cmb@php.net
-Status: Assigned +Status: Open -Assigned To: cmb +Assigned To:
 [2016-07-02 10:51 UTC] cmb@php.net
I have just downloaded php_enhanced_en.chm, and wasn't able to
reproduce the described behavior (Windows 10). Actually, the CHM
opens instanteneously here.

> please uncopyright the docs and php, and the web site.

I'm not sure which problem that would solve in your opinion, but
it's rather unlikely to happen.
 [2016-07-02 15:33 UTC] jim dot michaels at Jesusnjim dot com
please note that I did not extract the chm. I have no desire to. I ran it again and it does not do this anymore. so maybe Microsoft fixed the problem. beware of temp file cleaners, they rip out installed software in the process. programmers and engineers are not doing the right thing with the %temp% directory (yeah, you can put this in the address bar of windows-e). it's for short-term temporary use.
 [2016-07-03 11:11 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2016-07-03 11:11 UTC] cmb@php.net
> I ran it again and it does not do this anymore. so maybe
> Microsoft fixed the problem.

Well, then apparently this issue is not related to php.net. If
there are issues due to a bug in the help system, feel free to
file a bug report to Microsoft, or just use the distributed HTML
help.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Nov 28 02:01:26 2020 UTC