php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #72437 all xmlrpc docs are listed as experimental
Submitted: 2016-06-17 09:15 UTC Modified: 2016-06-17 10:34 UTC
From: konstantin dot krauter at brainformatik dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: 5.6.22 OS: Debian
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: konstantin dot krauter at brainformatik dot com
New email:
PHP Version: OS:

 

 [2016-06-17 09:15 UTC] konstantin dot krauter at brainformatik dot com
Description:
------------
all xmlrpc docs are listed as experimental since php4 and now in php7. 
why?

http://php.net/manual/en/function.xmlrpc-encode-request.php

Actual result:
--------------
Warning
This function is EXPERIMENTAL. The behaviour of this function, its name, and surrounding documentation may change without notice in a future release of PHP. This function should be used at your own risk.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-06-17 10:34 UTC] salathe@php.net
-Status: Open +Status: Not a bug
 [2016-06-17 10:34 UTC] salathe@php.net
The XML-RPC extension is marked as experimental in the PHP source code, by the presence of the EXPERIMENTAL file[1]. So long as the extension is marked as experimental in the source, the docs will reflect that.

[1] http://git.php.net/?p=php-src.git;a=blob;f=ext/xmlrpc/EXPERIMENTAL
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Oct 28 03:01:23 2020 UTC