php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #72422 typo: declaration argument should be string
Submitted: 2016-06-15 19:10 UTC Modified: 2016-06-16 11:03 UTC
From: tridays at qq dot com Assigned: cmb (profile)
Status: Closed Package: event (PECL)
PHP Version: Irrelevant OS: irrelevant
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tridays at qq dot com
New email:
PHP Version: OS:

 

 [2016-06-15 19:10 UTC] tridays at qq dot com
Description:
------------
In this page, I got

public bool EventConfig::avoidMethod ( int $method )

it should be:

public bool EventConfig::avoidMethod ( string $method )

just like example code below.

---
From manual page: http://www.php.net/eventconfig.avoidmethod
---


Expected result:
----------------
public bool EventConfig::avoidMethod ( string $method )

Actual result:
--------------
public bool EventConfig::avoidMethod ( int $method )

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-06-15 19:20 UTC] requinix@php.net
-Status: Open +Status: Verified -Package: Documentation problem +Package: event
 [2016-06-15 19:20 UTC] requinix@php.net
Confirmed that EventConfig::avoidMethod takes a string.
 [2016-06-16 11:02 UTC] cmb@php.net
Automatic comment from SVN on behalf of cmb
Revision: http://svn.php.net/viewvc/?view=revision&revision=339360
Log: Fix #72422: typo: declaration argument should be string
 [2016-06-16 11:03 UTC] cmb@php.net
-Status: Verified +Status: Closed -Assigned To: +Assigned To: cmb
 [2016-06-16 11:03 UTC] cmb@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed May 22 19:01:32 2019 UTC