php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #72329 gmp_div segFaults
Submitted: 2016-06-03 15:30 UTC Modified: 2016-06-04 06:27 UTC
From: raulrodriguez782 at gmail dot com Assigned:
Status: Closed Package: GNU MP related
PHP Version: 5.5.36 OS: OSX - El Capitan
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: raulrodriguez782 at gmail dot com
New email:
PHP Version: OS:

 

 [2016-06-03 15:30 UTC] raulrodriguez782 at gmail dot com
Description:
------------
I've reproduced this error on php 5.5.21, php 5.6.21 and php 7.0.7.

<?php 
gmp_div('123', '123');

It throws a seg fault

Test script:
---------------
<?php

1 == gmp_div('123', '123');

Actual result:
--------------
Segmentation fault

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-06-03 15:33 UTC] raulrodriguez782 at gmail dot com
Also reproduced in php 5.5.35
 [2016-06-03 15:35 UTC] raulrodriguez782 at gmail dot com
-Operating System: OSX +Operating System: OSX - El Capitan
 [2016-06-03 15:35 UTC] raulrodriguez782 at gmail dot com
To be more specific, this happens on OSX - El Capitan
 [2016-06-03 15:55 UTC] inefedor at gmail dot com
Please make sure you don't have XDebug enabled. Most probably it is the cause of your issue.

You might have display_startup_errors disabled in php.ini configuration: http://php.net/manual/en/errorfunc.configuration.php#ini.display-startup-errors
If that's the case then you may get some errors when you enable it
 [2016-06-04 06:27 UTC] raulrodriguez782 at gmail dot com
-Status: Open +Status: Closed
 [2016-06-04 06:27 UTC] raulrodriguez782 at gmail dot com
Thanks, disabling xdebug fixed the issue.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Mar 02 15:01:24 2021 UTC