php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #72314 rar will not compile.
Submitted: 2016-06-02 06:39 UTC Modified: 2016-06-02 12:06 UTC
From: miles dot t dot prower at gmail dot com Assigned: cmb (profile)
Status: Duplicate Package: rar (PECL)
PHP Version: 7.0.7 OS: Arch Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: miles dot t dot prower at gmail dot com
New email:
PHP Version: OS:

 

 [2016-06-02 06:39 UTC] miles dot t dot prower at gmail dot com
Description:
------------
Installed php-pear from the aur several years ago.
Recently Did update of system, php went from 5.6.16 to 7.0.7

rar extension isn't working, so did the same as error from long ago, ~php 5.4/5.5 upgrade.

pecl uninstall rar
pecl install rar


Expected result:
----------------
rar to install and work as before.

Actual result:
--------------
pecl install rar 
downloading rar-3.0.2.tgz ...
Starting to download rar-3.0.2.tgz (257,787 bytes)
.....................................................done: 257,787 bytes
125 source files, building
running: phpize
Configuring for:
PHP Api Version:         20151012
Zend Module Api No:      20151012
Zend Extension Api No:   320151012
building in /tmp/pear/temp/pear-build-rootfnAQ73/rar-3.0.2

.....
.....
.....

In file included from /usr/include/php/Zend/zend.h:39:0,
                 from /usr/include/php/main/php.h:35,
                 from /tmp/pear/temp/rar/rar.c:47:
/usr/include/php/Zend/zend_variables.h:141:15: note: expected ‘zval * {aka struct _zval_struct *}’ but argument is of type ‘zval ** {aka struct _zval_struct **}’
 ZEND_API void zval_add_ref(zval *p);
               ^~~~~~~~~~~~
/tmp/pear/temp/rar/rar.c: At top level:
cc1: warning: unrecognized command line option ‘-Wno-logical-op-parentheses’
Makefile:194: recipe for target 'rar.lo' failed
make: *** [rar.lo] Error 1
ERROR: `make' failed


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-06-02 12:06 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2016-06-02 12:06 UTC] cmb@php.net
Duplicate of bug #71399.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Nov 11 23:01:33 2019 UTC