php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7230 Configuration fails for Oracle 8.1.6
Submitted: 2000-10-15 21:36 UTC Modified: 2000-12-07 11:52 UTC
From: wbastow at ccahs dot health dot nsw dot gov dot au Assigned:
Status: Closed Package: *Configuration Issues
PHP Version: 4.0.3 OS: Redhat 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: wbastow at ccahs dot health dot nsw dot gov dot au
New email:
PHP Version: OS:

 

 [2000-10-15 21:36 UTC] wbastow at ccahs dot health dot nsw dot gov dot au
Running ./configure --with-apxs=/u1/app/http/bin/apxs --with-ldap=/usr/local/etc/openldap --with-oci8=/u1/app/oracle/product/8.1.6 --with-sybase=/opt/sybase-11.9.2 --enable-sigchild --disable-with-oracle

get the following at the end of configure run:

checking Oracle version... 7.3
configure: error: Unsupported Oracle version!

I modified configure to work here:

[wbastow@io php-4.0.3pl1]$ diff configure configure.new
24527,24528c24527,24528
<   if test -f "$OCI8_DIR/orainst/unix.rgs"; then
<       OCI8_VERSION=`grep '"ocommon"' $OCI8_DIR/orainst/unix.rgs | sed 's/  */:/g' | cut -d: -f 6 | cut -c 2-4`
---
>   if test -f "$OCI8_DIR/install/unix.rgs"; then
>       OCI8_VERSION=`grep 'rdbms' $OCI8_DIR/install/unix.rgs | sed 's/  */:/g' | cut -d: -f 2 | cut -c 1-3`



The unix.rgs file in orainst is empty and the file in the install directory doesn't contain ocommon.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-10-27 09:07 UTC] sniper@php.net
Have you updated some older version to 8.1.6 ??
I just installed 8.1.6 from scratch and the configure 
found the version just fine..

And better fix might be to just change the order of the checks for
the version.

--Jani
 [2000-10-27 09:08 UTC] sniper@php.net
Have you updated some older version to 8.1.6 ??
I just installed 8.1.6 from scratch and the configure 
found the version just fine..

And better fix might be to just change the order of the checks for
the version.

--Jani
 [2000-12-07 11:52 UTC] sniper@php.net
Reopen, if this still happens when using latest snapshot
from http://snaps.php.net/

--Jani
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Mar 03 20:01:29 2024 UTC