php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #72192 setimageopacity undefined
Submitted: 2016-05-11 08:56 UTC Modified: 2017-01-29 04:22 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: 282130106 at qq dot com Assigned:
Status: No Feedback Package: imagick (PECL)
PHP Version: 5.5.35 OS: CentOS
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: 282130106 at qq dot com
New email:
PHP Version: OS:

 

 [2016-05-11 08:56 UTC] 282130106 at qq dot com
Description:
------------
ImageMagick 7 , imagick 3.4.1 , php 5.5.7
setimageopacity undefined.



Test script:
---------------
$bg_img = new \Imagick();
$bg_img->newImage($width,$height,new \ImagickPixel('#000000'),'png');
$bg_img->setimageopacity(0.0);


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-01-17 23:08 UTC] danack@php.net
-Status: Open +Status: Feedback
 [2017-01-17 23:08 UTC] danack@php.net
You are correct, setImageOpacity is not present when Imagick is compiled against ImageMagick 7. This is because opacity has been removed from ImageMagick 7, and been replaced with alpha. 

I have just released Imagick 3.4.3RC2 that has the setImageAlpha method added. Please test it.

Also, if you would like to volunteer writing the Imagick migration guide for moving from ImageMagick 6 -> 7 I've made an issue here: https://github.com/mkoppanen/imagick/issues/166

In the meantime, the notes about the differences between ImageMagick 6 and 7 are here:
https://www.imagemagick.org/script/porting.php
 [2017-01-29 04:22 UTC] pecl-dev at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Jul 30 11:01:23 2021 UTC