php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #72104 FILTER_FLAG_NO_RES_RANGE applies to IPv6 addresses too
Submitted: 2016-04-26 07:09 UTC Modified: 2016-09-08 12:04 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: kroky6 at gmail dot com Assigned: cmb (profile)
Status: Closed Package: Filter related
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: kroky6 at gmail dot com
New email:
PHP Version: OS:

 

 [2016-04-26 07:09 UTC] kroky6 at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/filter.filters.flags
---
Description for FILTER_FLAG_NO_RES_RANGE says "This flag does not apply to IPv6 addresses."

In fact, it does apply and filters reserved IPv6 address ranges quite well from PHP 5.3. This commit adds the mentioned functionality:

https://github.com/php/php-src/commit/e90265ac978a5d92beb7c37ecf3107c2c5f1d7f5


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-04-26 16:55 UTC] cmb@php.net
-Status: Open +Status: Verified
 [2016-04-26 16:55 UTC] cmb@php.net
According to <https://3v4l.org/VX2US>, IPv6 addresses are
supported as of PHP 5.2.10 already.
 [2016-09-08 12:03 UTC] cmb@php.net
Automatic comment from SVN on behalf of cmb
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=340005
Log: Fix #72104: FILTER_FLAG_NO_RES_RANGE applies to IPv6 addresses too
 [2016-09-08 12:04 UTC] cmb@php.net
-Status: Verified +Status: Closed -Package: Documentation problem +Package: Filter related -Assigned To: +Assigned To: cmb
 [2016-09-08 12:04 UTC] cmb@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.

Also relevant: <http://svn.php.net/viewvc?view=revision&revision=340004>.
 [2020-02-07 06:06 UTC] phpdocbot@php.net
Automatic comment on behalf of cmb
Revision: http://git.php.net/?p=doc/en.git;a=commit;h=099acb26372ecdadbcefbb2b08d1416a44efe073
Log: Fix #72104: FILTER_FLAG_NO_RES_RANGE applies to IPv6 addresses too
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Jan 27 18:03:33 2022 UTC