php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #72041 Unknown type 18 sent by the server
Submitted: 2016-04-17 10:24 UTC Modified: 2020-12-10 11:29 UTC
From: janne dot saukkio at gmail dot com Assigned:
Status: Duplicate Package: PDO MySQL
PHP Version: 5.6.20 OS: Debian 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
50 - 49 = ?
Subscribe to this entry?

 
 [2016-04-17 10:24 UTC] janne dot saukkio at gmail dot com
Description:
------------
Apache2 error_log:
PHP Warning: PDO::prepare(): Unknown type 18 sent by the server. Please send a report to the developers ... on line 65
PHP Fatal error: Call to a member function execute() on boolean ... on line 66

My PHP version is 5.6.19-0+deb8u1 (Jessie doesn't have an update for PHP)
My MySQL version is 5.7.11

Example SQL code works perfectly on MySQL console and doesn't create an error.

Test script:
---------------
http://pastebin.com/YkKN1HdX

Create a PHP error by adding "?error=1" in the url


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-24 19:19 UTC] adambaratz@php.net
-Package: PDO related +Package: PDO MySQL
 [2020-12-10 11:27 UTC] nikic@php.net
I can't reproduce this running in 7.3 against MySQL 8.0.22.

There is also the similar report bug #72416, which claims this is a bug in the MySQL server: https://bugs.mysql.com/bug.php?id=82139

As I can't reproduce this, I would assume the server-side bug has been fixed (even though the report there wasn't closed).
 [2020-12-10 11:29 UTC] nikic@php.net
-Status: Open +Status: Duplicate
 [2020-12-10 11:29 UTC] nikic@php.net
Closing as a duplicate of bug #72416, as the root cause is clearly the same and that one has more info.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jan 23 02:01:25 2021 UTC