php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7203 Lack of calling tzset() in some php internal code
Submitted: 2000-10-14 04:27 UTC Modified: 2001-01-09 04:08 UTC
From: christian dot robert at polymtl dot ca Assigned:
Status: Closed Package: Date/time related
PHP Version: 4.0.3 OS: Linux Slackware 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: christian dot robert at polymtl dot ca
New email:
PHP Version: OS:

 

 [2000-10-14 04:27 UTC] christian dot robert at polymtl dot ca
I recently found a problem on a php piece of code 
who looks like:

putenv("TZ=$Some_TZ");  // Like "EST5EDT"
$val=  strftime("%Z");
echo "Timezone = ".$val;

It sometimes get the right value, sometimes some "near" garbage
values. Not repeateable (at random under apache).

it looks like that under standard linux(glibc2), all "time" related function
should call "C" function tzset() before first usage.

I see in the source that:  _php_mktime() is calling tzset() #if HAVE_TZSET

the strftime() function need this too (for linux at least)

thanks,
Xtian.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-02 17:58 UTC] derick@php.net

 [2001-01-09 04:08 UTC] sniper@php.net
Fixed in CVS. Thank you for pointing this out.

--Jani
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC