php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #72013 filter_var has FILTER_VALIDATE_DOMAIN but this not documented
Submitted: 2016-04-13 09:49 UTC Modified: 2018-04-09 10:33 UTC
Votes:10
Avg. Score:3.5 ± 1.1
Reproduced:9 of 10 (90.0%)
Same Version:3 (33.3%)
Same OS:0 (0.0%)
From: basko dot slava at gmail dot com Assigned: peehaa (profile)
Status: Closed Package: Filter related
PHP Version: 7.0.5 OS: Os X
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: basko dot slava at gmail dot com
New email:
PHP Version: OS:

 

 [2016-04-13 09:49 UTC] basko dot slava at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/filter.filters.validate
---

filter_var from php7 has FILTER_VALIDATE_DOMAIN but these filter not documented. Why? Any reason?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-07-01 22:31 UTC] asphp at dsgml dot com
None of the changes from: https://github.com/php/php-src/pull/826 have been documented.
 [2017-01-28 13:54 UTC] cmb@php.net
-Package: Documentation problem +Package: Filter related
 [2018-04-09 10:32 UTC] peehaa@php.net
Automatic comment from SVN on behalf of peehaa
Revision: http://svn.php.net/viewvc/?view=revision&revision=344641
Log: A parameter (FILTER_VALIDATE_DOMAIN) was added to filter_var in 2014 but never documented. This attempts to document it according to the notes on the original PR 826: https://github.com/php/php-src/pull/826

Fixes #72013

--
Provided by anonymous 90461 (kevin.boyd@gmail.com)
 [2018-04-09 10:33 UTC] peehaa@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: peehaa
 [2018-04-09 10:33 UTC] peehaa@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu May 19 21:04:10 2022 UTC