php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #72012 php7.0.3 unable to install sphinx client extension
Submitted: 2016-04-13 09:15 UTC Modified: 2016-04-13 09:25 UTC
From: 563268276 at qq dot com Assigned:
Status: Not a bug Package: sphinx (PECL)
PHP Version: 7.0Git-2016-04-13 (Git) OS: centos
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: 563268276 at qq dot com
New email:
PHP Version: OS:

 

 [2016-04-13 09:15 UTC] 563268276 at qq dot com
Description:
------------
in centos6.5 use php7.0.3 can not install sphinx client extension.

i try to use https://github.com/php/pecl-search_engine-sphinx
but i get error information forever

try to make get error information like
/root/sphinx-1.0.0/sphinx.c:62: 错误:expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘php_sphinx_client_new’
/root/sphinx-1.0.0/sphinx.c: 在函数‘php_sphinx_client_read_property’中:
/root/sphinx-1.0.0/sphinx.c:83: 警告:将一个整数转换为大小不同的指针
/root/sphinx-1.0.0/sphinx.c:85: 错误:‘zval’没有名为‘type’的成员
/root/sphinx-1.0.0/sphinx.c:95: 错误:提供给函数‘std_hnd->read_property’的实参太少
/root/sphinx-1.0.0/sphinx.c: 在函数‘php_sphinx_client_get_properties’中:
/root/sphinx-1.0.0/sphinx.c:110: 警告:将一个整数转换为大小不同的指针
/root/sphinx-1.0.0/sphinx.c:114:35: 错误:宏“ZVAL_STRING”传递了 3 个参数,但只需要 2 个
/root/sphinx-1.0.0/sphinx.c:114: 错误:‘ZVAL_STRING’未声明(在此函数内第一次使用)
/root/sphinx-1.0.0/sphinx.c:114: 错误:(即使在一个函数内多次出现,每个未声明的标识符在其
/root/sphinx-1.0.0/sphinx.c:114: 错误:所在的函数内也只报告一次。)
/root/sphinx-1.0.0/sphinx.c:115:98: 错误:宏“zend_hash_update”传递了 6 个参数,但只需要 3 个
/root/sphinx-1.0.0/sphinx.c:115: 错误:‘zend_hash_update’未声明(在此函数内第一次使用)
/root/sphinx-1.0.0/sphinx.c:119:37: 错误:宏“ZVAL_STRING”传递了 3 个参数,但只需要 2 个
/root/sphinx-1.0.0/sphinx.c:120:102: 错误:宏“zend_hash_update”传递了 6 个参数,但只需要 3 个
/root/sphinx-1.0.0/sphinx.c: 在函数‘php_sphinx_result_to_array’中:
/root/sphinx-1.0.0/sphinx.c:149: 错误:提供给函数‘add_assoc_string_ex’的实参太多
/root/sphinx-1.0.0/sphinx.c:151: 错误:提供给函数‘add_assoc_string_ex’的实参太多
/root/sphinx-1.0.0/sphinx.c:156: 错误:提供给函数‘add_assoc_string_ex’的实参太多
/root/sphinx-1.0.0/sphinx.c:158: 错误:提供给函数‘add_assoc_string_ex’的实参太多
/root/sphinx-1.0.0/sphinx.c:169: 错误:提供给函数‘add_next_index_string’的实参太多
/root/sphinx-1.0.0/sphinx.c: 在函数‘zim_SphinxClient___construct’中:
/root/sphinx-1.0.0/sphinx.c:326: 警告:将一个整数转换为大小不同的指针



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-04-13 09:25 UTC] tony2001@php.net
-Status: Open +Status: Not a bug
 [2016-04-13 09:25 UTC] tony2001@php.net
Use branch php7 of that repository.
The master is currently PHP5-only, while 'php7' is PHP7-only.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 07 18:01:27 2020 UTC