php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71949 simplexml_load_string() function not exists
Submitted: 2016-04-03 09:38 UTC Modified: 2016-04-03 09:46 UTC
From: andris dot petrams at gmail dot com Assigned:
Status: Not a bug Package: SimpleXML related
PHP Version: 7.0.5 OS: Linux UBUNTU 15.10 x86_64
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: andris dot petrams at gmail dot com
New email:
PHP Version: OS:

 

 [2016-04-03 09:38 UTC] andris dot petrams at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/function.simplexml-load-string
---
$xml = simplexml_load_string("<root><test>TEST</test></root>");



Test script:
---------------
if(function_exists('simplexml_load_string')){
$xml = simplexml_load_string("<root><test>TEST</test></root>");
print_r($xml);
}
else {
echo "function not exists";
}

Expected result:
----------------
SimpleXMLElement Object
(
    [test] => TEST
)

Actual result:
--------------
function not exists

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-04-03 09:46 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2016-04-03 09:46 UTC] requinix@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Install php7.0-xml.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Nov 29 15:05:53 2022 UTC