php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7192 Non-working Sablotron in 4.0.3, DL_UNLOAD problems
Submitted: 2000-10-13 13:38 UTC Modified: 2001-01-16 05:30 UTC
From: ljb at devco dot net Assigned:
Status: Closed Package: Sablotron XSL
PHP Version: 4.0.3pl1 OS: Suse Linux 6.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ljb at devco dot net
New email:
PHP Version: OS:

 

 [2000-10-13 13:38 UTC] ljb at devco dot net
Hi.

I've had quite a few problems getting PHP 4.0.3 and sablot going at the same time on Solaris, using gcc 2.95.2.

My configure line:
./configure --enable-track-vars --with-apxs=/opt/apache-1.3.12/bin/apxs --enable-xml --without-mysql  --enable-debug --with-sablot

Sablotron I downloaded and compiled from source (0.44),
with its builtin Expat, and installed it in /usr/local. 

First problem was DL_UNLOAD reference, which I solved by putting
#define HAVE_LIBDL 1 in php_config.h

Second was this, when trying to start Apache:

Cannot load /opt/apache-1.3.12/libexec/libphp4.so into server: ld.so.1: /opt/apache-1.3.12/bin/httpd: fatal: relocation error: file /usr/local/lib/libsablot.so.0: symbol __builtin_new: referenced symbol not found

I suspected this was because libsablot.so.1 was not linked against the stdc++ library.  But statically linking in stdc++ did not solve the problem. 

Any ideas?

I'm not subscribed to the list, please CC me on replies.

Leon.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-01-03 12:23 UTC] ljb at devco dot net
Got same problem under Linux with Apache 1.3.14

Here is my configure command:

./configure \
	--with-mysql=/usr \
	--with-gd=/usr \
	--with-jpeg-dir \
	--with-png-dir \
	--with-tiff-dir \
	--with-zlib-dir \
	--with-ttf \
	--with-mm \
        --with-config-file-path=/usr/local/apache/conf \
	--with-apxs=/usr/local/apache/bin/apxs \
	--enable-versioning \
	--enable-memory-limit \
	--enable-track-vars \
	--enable-magic-quotes \
        --with-sablot \
        --enable-sablot-errors-descriptive \
	--enable-safe-mode \
	--enable-sysvsem \
	--enable-sysvshm \
        --enable-yp \
        --disable-debug

Following WORKAROUND does work on my system.

- remove the config.cache file
- call configure without the sablotron option
- call configure with the sablotron options (don not touch config.cache)
- make; make install

Now it works, don't know why


 [2001-01-04 08:08 UTC] sniper@php.net
Have you tried reducing the configure options to minumum?
If not please do and then add the other options one by
one until the problem raises it's ugly head again.
Remember to delete config.cache after every configure.

And please send me the config.log you get when it doesn't
work.

--Jani

 [2001-01-11 15:47 UTC] sniper@php.net
Please try the latest CVS snapshot from http://snaps.php.net/ as there
have been a few fixes related to this bug.

--Jani
 [2001-01-16 05:30 UTC] sniper@php.net
Use reported problem solved in 4.0.4.

--Jani
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jul 04 19:01:16 2020 UTC