php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71846 Curl is not found when giving external path to curl on Windows
Submitted: 2016-03-17 17:22 UTC Modified: 2016-03-18 16:16 UTC
From: starkloff dot kristian at gmail dot com Assigned:
Status: Not a bug Package: Compile Warning
PHP Version: 7.0.4 OS: Windows Server 2012 R2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: starkloff dot kristian at gmail dot com
New email:
PHP Version: OS:

 

 [2016-03-17 17:22 UTC] starkloff dot kristian at gmail dot com
Description:
------------
* Compile libcurl 32 bit (https://curl.haxx.se/download.html)
* Compile PHP7 (32 bit architecture) on Windows (VS 2015) with these additional parameters:
   * --with-extra-includes=C:\Path\to\libcurl\include
   * --with-extra-libs=C:\Path\tolibcurl\lib
   * --disable-all --without-libxml --without-dom --enable-sockets --enable-embed --enable-com-dotnet --enable-ctype --enable-odbc --with-openssl --with-curl --enable-debug


Expected result:
----------------
Compiles PHP 7 with libcurl from external paths

Actual result:
--------------
Checking for wspiapi.h ...  <in default path>
Enabling IPv6 support
Enabling SAPI sapi\embed
Checking for library oleaut32.lib ... <in LIB path> OleAut32.Lib
Enabling extension ext\com_dotnet
Checking for mscoree.h ...  <in default path>
Enabling extension ext\ctype
Checking for library libcurl_a.lib;libcurl.lib ... <in extra libs path>
Checking for curl/easy.h ...  <not found>
Checking for curl/easy.h ...  D:\trunk\libext\php7.0-embed\build\..\..\..\libext\libcurl\include
Checking for library ssleay32.lib ... <in extra libs path>
Checking for library libeay32.lib ... <in extra libs path>
Checking for library winmm.lib ... <in LIB path> WinMM.Lib
Checking for library wldap32.lib ... <in LIB path> Wldap32.Lib
Checking for library zlib_a.lib;zlib.lib ... <not found>
WARNING: curl not enabled; libraries and headers not found

Enabling extension ext\date
Checking for library odbc32.lib ... <in LIB path> odbc32.lib
Checking for library odbccp32.lib ... <in LIB path> odbccp32.lib
Checking for sql.h ...  <in default path>
Checking for sqlext.h ...  <in default path>
Enabling extension ext\odbc
Checking for library ssleay32.lib ... <in extra libs path>
Checking for library libeay32.lib ... <in extra libs path>
Checking for library crypt32.lib ... <in LIB path> Crypt32.Lib
Checking for openssl/ssl.h ...  D:\trunk\libext\php7.0-embed\build\deps\include
Enabling extension ext\openssl
Enabling extension ext\pcre
Enabling extension ext\reflection
Checking for library ws2_32.lib ... <in LIB path> WS2_32.Lib
Checking for library Iphlpapi.lib ... <in LIB path> IPHlpApi.Lib
Checking for winsock.h ...  <in default path>
Enabling extension ext\sockets
Enabling extension ext\spl
Checking for timelib_config.h ...  ext/date/lib
Enabling extension ext\standard

Creating build dirs...
Generating files...
Generating Makefile
Generating main/internal_functions.c
Generating main/config.w32.h
Generating phpize
Done.



Enabled extensions:
-----------------------
| Extension  | Mode   |
-----------------------
| com_dotnet | static |
| ctype      | static |
| date       | static |
| odbc       | static |
| openssl    | static |
| pcre       | static |
| reflection | static |
| sockets    | static |
| spl        | static |
| standard   | static |
-----------------------


Enabled SAPI:
-------------
| Sapi Name |
-------------
| embed     |
-------------


----------------------------------------------
|                 |                          |
----------------------------------------------
| Build type      | Debug                    |
| Thread Safety   | Yes                      |
| Compiler        | MSVC14 (Visual C++ 2015) |
| Architecture    | x86                      |
| Optimization    | disabled                 |
| Static analyzer | disabled                 |
----------------------------------------------

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-03-18 16:16 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2016-03-18 16:16 UTC] ab@php.net
Thanks for the report. According to the configure output, zlib is missing. You can find all the prebuilt dependencies under http://windows.php.net/downloads/php-sdk/ . Also, please check https://wiki.php.net/internals/windows/stepbystepbuild for the build environment setup instructions. All the core dependency libraries have to be put in a certain path so then you don't need to pass the *extra* options.

Thanks.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Nov 29 08:01:23 2020 UTC