php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71814 The function openssl_dh_compute_key(); d'ont have resource
Submitted: 2016-03-13 14:35 UTC Modified: 2016-03-14 04:06 UTC
From: marcosptf at yahoo dot com dot br Assigned:
Status: Not a bug Package: OpenSSL related
PHP Version: Irrelevant OS: Fedora 20
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: marcosptf at yahoo dot com dot br
New email:
PHP Version: OS:

 

 [2016-03-13 14:35 UTC] marcosptf at yahoo dot com dot br
Description:
------------
Hello to everyone!

we have a problem in openssl module.
The function openssl_dh_compute_key ( string $pub_key , resource $dh_key );, 
need two parameters to work, a (string) public key and a (resource) dh_key.
http://php.net/manual/en/function.openssl-dh-compute-key.php

The problem is that the second parameter, is impossible to get, because no one
php function return this type of resource, but i need write a php test to coverage this function.

How we can do to resolve this problem?

Thanks from @php-sp Brazil

:-)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-03-14 04:05 UTC] requinix@php.net
Try openssl_pkey_new().
 [2016-03-14 04:06 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2016-03-14 04:06 UTC] requinix@php.net
Made a bug to document the remaining OpenSSL functions.
https://bugs.php.net/bug.php?id=71817
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Jan 23 10:03:35 2022 UTC