php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #71761 Gmagick::deconstructimages() returns a Gmagick object, not void
Submitted: 2016-03-10 00:15 UTC Modified: 2016-07-10 12:55 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: benjamin dot morel at gmail dot com Assigned: cmb (profile)
Status: Closed Package: gmagick (PECL)
PHP Version: Irrelevant OS: N/A
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: benjamin dot morel at gmail dot com
New email:
PHP Version: OS:

 

 [2016-03-10 00:15 UTC] benjamin dot morel at gmail dot com
Description:
------------
Gmagick::deconstructimages() returns a Gmagick object, not void:
http://php.net/manual/en/gmagick.deconstructimages.php

Source:
https://github.com/vitoc/gmagick/blob/master/gmagick_methods.c#L696-L719

Equivalent in Imagick:
http://php.net/manual/en/imagick.deconstructimages.php

Expected result:
----------------
public Gmagick Gmagick::deconstructimages ( void )

Actual result:
--------------
public void Gmagick::deconstructimages ( void )

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-03-10 00:18 UTC] benjamin dot morel at gmail dot com
Also, the return value should be documented as:
"Returns a new Gmagick object on success."

It does not return self.
 [2016-03-10 17:53 UTC] cmb@php.net
-Package: Documentation problem +Package: gmagick
 [2016-07-10 12:54 UTC] cmb@php.net
Automatic comment from SVN on behalf of cmb
Revision: http://svn.php.net/viewvc/?view=revision&revision=339629
Log: Fix #71761: Gmagick::deconstructimages() returns a Gmagick object, not void
 [2016-07-10 12:55 UTC] cmb@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: cmb
 [2016-07-10 12:55 UTC] cmb@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.
 [2020-02-07 06:07 UTC] phpdocbot@php.net
Automatic comment on behalf of cmb
Revision: http://git.php.net/?p=doc/en.git;a=commit;h=1e31cb2509e4ac16030b8afe3aa10df625651dbd
Log: Fix #71761: Gmagick::deconstructimages() returns a Gmagick object, not void
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon May 27 00:01:31 2024 UTC