|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71760 Receiving error in pecl install
Submitted: 2016-03-09 16:45 UTC Modified: 2016-03-31 15:13 UTC
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: mdray at 4dct dot com Assigned: koubel (profile)
Status: Closed Package: rrd (PECL)
PHP Version: 7.0.4 OS: Lubuntu 15.10
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: mdray at 4dct dot com
New email:
PHP Version: OS:


 [2016-03-09 16:45 UTC] mdray at 4dct dot com
I am receiving and error while trying to install the rrd extension for PHP 7.0.

I have uninstalled and reinstalled PHP and pear numerous times, yet the error is still there. 



Test script:
downloading rrd-2.0.0.tgz ...
Starting to download rrd-2.0.0.tgz (19,212 bytes)
......done: 19,212 bytes
12 source files, building
running: phpize
Configuring for:
PHP Api Version:         20151012
Zend Module Api No:      20151012
Zend Extension Api No:   320151012
building in /tmp/pear/temp/pear-build-rootFxXUYZ/rrd-2.0.0
running: /tmp/pear/temp/rrd/configure --with-php-config=/usr/bin/php-config
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for PHP prefix... /usr
checking for PHP includes... -I/usr/include/php/20151012 -I/usr/include/php/20151012/main -I/usr/include/php/20151012/TSRM -I/usr/include/php/20151012/Zend -I/usr/include/php/20151012/ext -I/usr/include/php/20151012/ext/date/lib
checking for PHP extension directory... /usr/lib/php/20151012
checking for PHP installed headers prefix... /usr/include/php/20151012
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... no
configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.
checking for gawk... no
checking for nawk... nawk
checking if nawk is broken... no
checking for rrdtool support... yes, shared
checking for rrdtool... /usr/bin/rrdtool
checking for rrdtool header files in default paths... not found
configure: error: Please reinstall the rrdtool distribution
ERROR: `/tmp/pear/temp/rrd/configure --with-php-config=/usr/bin/php-config' failed


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2016-03-09 16:50 UTC] mdray at 4dct dot com
I have also reinstalled rrdtool several times. I am still receiving the exact same error.
 [2016-03-24 12:26 UTC] mdray at 4dct dot com
Is there anyone that can provide any information on this error I am receiving?
 [2016-03-24 13:26 UTC]
It seems that rrd development library isn't correctly installed, there is line at the end of configure output
checking for rrdtool header files in default paths... not found

You have to have installed development libraries/packages for rrd tool. Try to find rrd tool development package in your distro.
 [2016-03-29 15:14 UTC]
-Status: Open +Status: Feedback
 [2016-03-30 00:53 UTC] mdray at 4dct dot com
-Status: Feedback +Status: Open
 [2016-03-30 00:53 UTC] mdray at 4dct dot com
I tried again, this time with Opensuse Leap.   And I have received the same error.   Could it be that it is looking for the rrdtool directory in a different place than it is located these 2 systems?
 [2016-03-30 13:08 UTC] mdray at 4dct dot com
Well...   I used php 5.5.14 on Opensuse Leap 42.1 and it worked perfectly after reinstalling rrdtool-devel.   

I will stick with this configuration for the time being.  

 [2016-03-31 15:13 UTC]
-Status: Open +Status: Closed -Assigned To: +Assigned To: koubel
 [2016-03-31 15:13 UTC]

You can see tests for searching rrd.h on around line 32.

You can also specify whatever path for rrd tool development files within ./configure call, but you must compile extension directly through ./configure, not pecl install.
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Sep 19 13:03:37 2021 UTC