php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71715 Call to undefined function mb_strtolower()
Submitted: 2016-03-05 14:13 UTC Modified: 2016-03-07 18:28 UTC
From: NielsNL at nielsnl dot nl Assigned: cmb (profile)
Status: Not a bug Package: mbstring related
PHP Version: 7.0.4 OS: Ubuntu
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: NielsNL at nielsnl dot nl
New email:
PHP Version: OS:

 

 [2016-03-05 14:13 UTC] NielsNL at nielsnl dot nl
Description:
------------
The function seems to be not existing, I get this error:
Call to undefined function mb_strtolower()
---
From manual page: http://www.php.net/function.mb-strtolower
---


Test script:
---------------
echo mb_strtolower("TXT");


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-03-05 17:55 UTC] php at mcq8 dot be
Is mbstring enabled?
As the documentation (http://php.net/manual/en/mbstring.installation.php) describes, it is not enabled by default.
If it is not, the functions will indeed be undefined.
 [2016-03-05 17:57 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Package: Strings related +Package: mbstring related -Assigned To: +Assigned To: cmb
 [2016-03-05 17:57 UTC] cmb@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Like php at mcq8 dot be said: check that mbstring is enabled.
 [2016-03-05 19:23 UTC] NielsNL at nielsnl dot nl
Installing the module did the trick. But I didn't find any obvious documentation about it not being enabled by default. Thanks for the tip.
I would like it to show up near the "(PHP 4 >= 4.3.0, PHP 5, PHP 7)" part on the mb_strtolower page for instance. With a small icon "install instructions".
I thought it was a bug because roundcube stopped working after an update of PHP.
 [2016-03-07 18:28 UTC] cmb@php.net
> I would like it to show up near the "(PHP 4 >= 4.3.0, PHP 5, PHP
> 7)" part on the mb_strtolower page for instance. With a small
> icon "install instructions".

The installation instructions are already (indirectly) available
via the breadcrumb menu (on top of the page) and via the function
menu (on the right); one just has to go to the start page of the
extension's book. In my opinion that is sufficient, and adding
another way to navigate to the installation instructions would be
more confusing then helpful.

Of course, that is just my personal opinion – feel free to file
a feature request to add such an icon. :)
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Nov 28 01:05:53 2022 UTC