php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71702 Seg fault - continuation of #71492
Submitted: 2016-03-02 15:35 UTC Modified: 2016-08-26 21:49 UTC
From: Birman at Cerberox dot com Assigned:
Status: Closed Package: PCRE related
PHP Version: 7.0.3 OS: CentOS 7.1.1503
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: Birman at Cerberox dot com
New email:
PHP Version: OS:

 

 [2016-03-02 15:35 UTC] Birman at Cerberox dot com
Description:
------------
This is continuation of #71492. I tried to set it to Re-Opened as instructed, but it kept saying I'm not allowed to change the bug to that state.

Hi! Sorry for late reply, got a bit occupied.
I've been monitoring the situation and the segmentation faults are not entirely gone. There is a lot less of them now though, however, they now occur at very fixed intervals: there's a series of seg faults happening after every 24 hours and ~1 second. First it's 10 seg fault errors, then 35 minutes later 11 seg fault errors and then some individual cases over the night. This all repeats every 24 hours and it always starts almost exactly at the same time.
The web service experience is better though as I no longer experience ERR_NO_RESPONSE messages during loading and I haven't heard any complaints from users either.
Unfortunately I'm no longer able to produce stacktraces, because after installing PHP7, the instructions I got from here back when I made another bug report simply do not work anymore. The first trace I posted here was generated via a dirty method (which's instructions I also got from here) by running httpd via gdb. However, the web service becomes pretty much unusable during this, because loading a simple page can take 2 minutes or even longer and I can't keep  it this way for hours.
PCRE Library version according to phpinfo(): 8.37 2015-04-28


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-08-20 13:32 UTC] cmb@php.net
Follow-up to bug #71492.

> PCRE Library version according to phpinfo(): 8.37 2015-04-28

The issue might have been solved in 8.38. Consider to update.

Anyhow, without a reproduce script or at least a backtrace it's
unlikely that we can find and fix the bug.
 [2016-08-26 21:49 UTC] Birman at Cerberox dot com
-Status: Open +Status: Closed
 [2016-08-26 21:49 UTC] Birman at Cerberox dot com
It seems that 8.38 indeed has fixed it since error logs are now really empty and no longer contain seg faults over the course of couple of months now.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Oct 19 09:01:26 2019 UTC