php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71552 string function implode does not allow left shift arrows
Submitted: 2016-02-09 03:57 UTC Modified: 2016-02-09 06:55 UTC
From: yuvaaji at gmail dot com Assigned:
Status: Not a bug Package: Output Control
PHP Version: 5.6.18 OS: Debian Ubuntu 15.10
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: yuvaaji at gmail dot com
New email:
PHP Version: OS:

 

 [2016-02-09 03:57 UTC] yuvaaji at gmail dot com
Description:
------------
implode('<<', $array) yields improper result. Result contains array from 2nd values.

Test script:
---------------
implode('<<', $array);

Expected result:
----------------
Networking Concepts<<Principles and Concepts<<Information Technology

Actual result:
--------------
Networking Concepts< Array

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-02-09 06:55 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2016-02-09 06:55 UTC] requinix@php.net
1. Do a View Source to see the actual output of your PHP code.
2. Use print_r() or var_dump() to see what $array actually contains.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Aug 13 08:05:44 2022 UTC