php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #71457 Unable to load dynamic library '/usr/lib/php/modules/haru.so'
Submitted: 2016-01-26 16:39 UTC Modified: 2016-01-27 09:54 UTC
From: dartme18 at gmail dot com Assigned:
Status: Not a bug Package: haru (PECL)
PHP Version: 7.0.2 OS: Archlinux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: dartme18 at gmail dot com
New email:
PHP Version: OS:

 

 [2016-01-26 16:39 UTC] dartme18 at gmail dot com
Description:
------------
It looks like haru isn't compatible with the latest version of php

Test script:
---------------
# pecl install haru-1.0.4

Expected result:
----------------
Successful installation output for the haru wrapper.

Actual result:
--------------
pecl/haru requires PHP (version >= 5.1.3, version <= 6.0.0, excluded versions: 6.0.0), installed version is 7.0.2 
No valid packages found
install failed

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-01-27 09:54 UTC] tony2001@php.net
-Status: Open +Status: Not a bug
 [2016-01-27 09:54 UTC] tony2001@php.net
There is a separate php7 branch with PHP7 support.
No, it's not possible to install it with pecl command at the moment, but that's something I can't change.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Jan 20 03:03:35 2022 UTC